Power windows stopped working on my E36, any ideas?

My '93 E36 320i lost power to the electric windows (fronts only fitted in my car) yesterday, and I'm after some advice of what to look for before I rip
the centre console out. Sunroof works fine, so I'm pretty sure it's not the comfort relay, and the fuse is fine (swapped for the 10A rear fogs fuse, and those worked with the fuse from the windows). There's no power to the window switches at all.
Everything was fine until yesterday when I swapped the phone cradle on the Nokia CARK91 that was fitted long ago with one that is compatible with the new Nokia phones. It only required disconnecting the old cradle, plugging the new one into the Nokia control box, and removing the old cradle. Rather than take the centre console out I carefully slid the old cable out, which was routed down the right hand side of the console. I can only assume that in doing so I must have pulled a connector apart. Are there any connectors for the window switches there? I lifted the gearstick boot and found a connector with brown + violet/green/yellow on the left side, but this seems to be a connector for the hood switch to connect to the factory alarm system (which I don't have, I had a 3rd party alarm fitted).
Does anyone have any pictures of the wiring that is fed around the sides of the gear boot under the centre console, so I have an idea of what I'm looking for? Or any suggestions on what I'm looking for when I take the centre console out?
Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Typical, just after posting this I noticed that the wiring diagram I was looking at was obviously not for my car as it had a 30A fuse rather than the 10A mine has in F33. Found the only diagram in the Bentley manual that had the 10A and realised I had a switch on the dash - I guess that's the automatic cutout shown in the diagram. I guess I may have knocked the connector behind that, so I'm taking the panel off under the steering later to see if that's the problem. Hopefully it's as simple as that :)
Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Spack wrote on Fri, 18 Mar 2005 09:34:01 -0000:

I'll chalk that up to experience then. The bottom connector on the breaker had come off. At least I've got my windows back, with no aircon I'm going to need the windows open now it's warmed up :)
Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You know, if you're just going to talk to yourself, you don't really need to post to a newsgroup. :-}
Randy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Damn, you interrupted my monologue :P
Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.