Starting problem with E36 325 (1993)

Hi,
Has anyone had an intermittent starting problem with the above? What seems to happen is: when it doesn't start immediately when the key is turned - from then on it is in the wrong 'mode' (perhaps from a fuel
injection point of view?). It will start if I just hold it turning over for around 5 - 10 mins and when it catches, keep the starter motor turning for another 10 seconds or so. This only happens about once a month - but is pretty annoying. All other times it starts straight away. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've had similar problems. According to the AA guy who came out to me when it first happened, it's a common problem with some beemers (and some other car types). Also happens if start then immediately and stop engine from cold. Won't (easily) restart. Now have to ban wife from moving car off drive and stopping the engine when she wants access to the garage. If she drives it around for a bit then it's OK.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I get a similar problem with a 95 323i. If I put the key in the ignition and dont start it straight away it wont start. I have to take the key out of the ignition ang wait about 3 - 5 seconds and then try again. If I cannot hear the fuel pump in the back it wont start. I suspect the immobilizer but I am not 100% sure. let me know if you find a fix

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.