Tail light bad connection? e46

Hello all,
I have a LR tail light that occassionally dims and then gets bright again. I have replaced the tail light bulbs (2) with no help as advised by the "stealership". The dimming also causes the warning
light indicator to come on sometimes and then it goes out.
I have looked at the tail light assembly and it seems to be a bad connection or a bad connector.
Any ideas to how I can have this fixed? My CPO warranty may not cover this.
Car is an 2002 325i.
TIA, William
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There is a long discussion and possible fix at http://forums.bimmerforums.com/forum/index.php Seems that the wiring harness gets worn in some cases and causes that problem among a few others. The harness goes from the trunk and into the body of the car near the left hinge and through repeated flexing it get worn and can even cause a fire. The harness has an additional covering there for protection and has to be moved out of the way to see If there is damage [many pictures of damage at that site] Most people had some kind of damage after looking. BMW know of the problem and sells new wiring harness, fixes can be seen at that site. You'll have to look around to find it, use the search engine.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
William,
On my car, I had a similar problem with the brake light. After days and weeks of troubleshooting, I tracked the problem to corroded contact area. If you look at the areas where contacts are made in taillight assembly, you might come to discover that there are holes around the contact areas. I am not sure if you will have the same problem, but from what you describe, it seems like an intermittent connection issue.
Best regards
weng94 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks a bunch to all, I have found the contacts to be corroded and have got them fixed.
Regards,
William
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.