Throttle response question

I've got a 1995 318Ti with an M42 4 cylinder and here is my question. The car runs perfectly in every way except this. When I first start it up in the morning, the throttle is sluggish until I hit 3500 to 4 grand
on the tac. Then its perfect for the rest of the day. I had a 1991 318 with an M42 and it was the same for all 7 years I owned that car. Any ideas? I don't think I need to fix anything, I'd like to just have an explanation.
Thank you in advance.
Glenn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds normal to have a "sluggish" cold throttle response given the richer fuel mixture. Of course, revving your engine to 3,500~4000 when cold isn't the best path to a long motor life.
Tom K.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I usually let it warm up first and always notice the response issue while that's happening. I know it can't be terrible but it seems weird.
Thanks.
Glenn

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hello Glenn,
What I do, I take the cold air valve out and clean it with some cleaner. So that the mechanism is not blocked by rubbish.
To find the thing look for a rubber tube from the airintake which passes the throttle valve. In between is the cold air valve, it has 2 hoses in and 1 power cable in. Size around 10 cm long, 4 cm wide, but that's in my car.
Best regards, Marcel, '92 525i 337.xxx km.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you very much. i will look for that.
Have a great day!
Glenn

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.