Turning indicator problem

HI There,
I've got a '93 BMW e36 325i Automatic, with 170000kns on the clock. Recently, I have a problem where the turn indicator does not flash at
interval. Sometimes, it stays on all the time, without any flashing, and sometimes, the light even did not switch off, even I manually switch off the lights.
Any idea why such a phenomenon?
Any ideas are welcomed. Thank you in advance.
Many Thanks and Kind Regards, Joe.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just a hunch here, but do you imagine the turn signal switch itself is failing?
The turn signal stalk controls the signals AND the high beams. The switch sounds like it is failing internally, preventing the signals from signaling, and the high beams remain on even after you switch the lights off.
The next time you notice trouble, try wiggling the turn signal stalk to see if you can change the symptoms. If this works, then I'd be looking at buying a new switch ...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi,
Thanks very much for the advise. I will try to play the switch around, and see if the problem can be recitifed.
Joe.
Jeff Strickland wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.