Unexplained stalling

Have 1984 528i E28 289,000 Km. About 2 weeks ago engine died while driving. After about 1 minute motor restarted as if nothing was wrong. This happened
several more times. Noticed that the tacho went immeadiately to zero. Since then no further problem. Suspect Motronic unit or one of the sensors. Has anybody had this experience and any suggestions what is the best place to start looking.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi, K and M, try checking the engine to body earth ????? also there is a earth lead that jumps over one of the engine mounts, (exhaust manifold side) check this out, the engine earths through this lead from the subframe, sometimes the subframe becomes insulated due to road grime etc, Fitzy

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kay & Mike Wharton wrote:

check the fuel pump relay, when they go dodgy the engine will cut out for no reason at all and will start again after about 30 seconds or so
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Never suspect the ECU until you've checked the simple things. First are the two relays - main and fuel pump.
--
*I'm pretty sure that sex is better than logic, but I can't prove it.

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Your car is Jetronic-L, not Motronic.
Could be the fuel pump relay. I don't think Jet-L cars have the equivalent of a Motronic relay, otherwise that'd be my first suspect.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Fuel getting through? Pump, wiring, air lock in pipe after running out of fuel.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.