Valve clatter?

E34 M50TU engine 170K with regular oil changes throughout it's life. Got to work this morning, and noticed quite a loud regular tapping coming from the engine. Sounded like a severe tappet noise.
An hour or so later, switched the engine on to let a work mate hear it, and it was still there but was hardly noticeable. Starting it to go home, engine sounded quite normal, and was still OK when I got home. Any ideas of the cause? Are these engines known for having the occasional sticky hydraulic tappet, because that is definitely what it sounded like, and it would explain why it apparently cured itself. Mike.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

...
it
In colder weather mine usually clatters for a few seconds on startup. Sometimes it lasts a few minutes until I get out on the main road and speed up. It doesn't bother me at all and I don't worry about it. It has 164k miles and has done it from at least 100k.
The thinner the oil, the less it will happen. I usually use 15W40 because it's cheaper and I feel more comfortable with thicker oil. With 10W40 the problem is less. I had some Castrol RS 0W40 from Halfords for half price and the tappets never made a sound. However, 1. it's 35 a bottle at full price, 2. the bottles are only 4L so you need two for each oil change, 3. my engine does use some oil, although it doesn't smoke, but with that stuff I got through nearly four bottles before the oil needed changing again. Shame, because I genuinely think the engine had a bit more power.
I've never had the noise come on after the engine was started. With yours being a vanos version it could be that and not a tappet.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'm familiar with that valve noise. Mine does it for maybe a minute or so, after starting first thing in the morning. The noise I had happened after I'd driven a few miles to work, and sounded like one tappet with really excessive clearance, It was really loud. Hasn't done it again since, so I'm not worried about it, just intrigued about what causeed it. Mike.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I switched to synthetic and the clatter essentially went away. My 318ic has 143k miles. Fred
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

AFAIC a light tappet noise starting from cold, which is all mine makes, is almost normal on engines with hydraulic tappets. Certainly nothing to be concerned about, and mine has done 170k. Mike.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.