Where's O2 Sensor Bank 1 Sensor 1 for 1997 318is?

OBD scanner shows P0130 (O2 sensor Bank 1 Sensor 1) and P0135 (O2 heated circuit for sensor Bank1 Sensor 1). Autozone says 1997 318is has 4 sensors. 3 before catalytic converter,
and one behind. Crawling under the car, I only see 2. One before and one after catalytic converter.
Questions: 1. How many O2 sensors/monitors does '97 318is really have? 2. Where is Bank 1 Sensor 1?
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
To my knowledge, it should have 2, one before and one after the CAT.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bank 1 Sensor 1 is upsteam of the catalyst.
Your car has 2 sensors, one upstream of the catalyst and one downstream as you have observed and Jeff pointed out and as shwon below.
http://www.realoem.com/bmw/showparts.do?model 71&mospidG426&btnr_0259&hg&fg
liem00 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bank 1 Sensor 1 is upsteam of the catalyst.
Your car has 2 sensors, one upstream of the catalyst and one downstream as you have observed and Jeff pointed out and as shown below.
http://www.realoem.com/bmw/showparts.do?model 71&mospidG426&btnr_0259&hg&fg
liem00 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you both for the valuable info.
Pashlipops wrote:

http://www.realoem.com/bmw/showparts.do?model 71&mospidG426&btnr_0259&hg&fg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A follow-up question. I ended up buying two universal O2 sensors (#USOS-4000) to replace the existing ones at this place; see the last one on the list: http://replacement.autopartswarehouse.com/parts/autopartswarehouse/quote.jsp?year 97&product010-61263&application0334014&part=Oxygen%20Sensor&dp=true
The old sensors have 4 wires, 2 whites, 1 black, 1 grey. New sensors have the same number of wires and colors. I made wire-by-wire connection, but I still get engine faults: P0130 & P0136. Any idea?
Thanks, Liem
liem00 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.