Windshield defroster - Connector X162 - Fuse #9

The Patient: 1994 740iL
I am still on my mission to resolve my blown Fuse #9 issue.
The problem seems to occur when I get the "ding" that the ambient
temperature crosses the 38 degree setpoint. My only knowledge of the failure is that my horns quit working.
Per the prints, Fuse #9 feeds K19 compressor control relay, the auxillary water pump, washer jet heaters and windshield defogger.
I replaced the fuse, drove with the IHKA brain box removed and suffered no failure.
I reinstalled the IHKA board and disconnected the aux water pump and the fuse blew.
I replaced the fuse and disconnected both jet nozzle heaters and the fuse blew.
I replaced the fuse and disconnected K19 compressor control relay and the fuse blew.
The only thing left that can possibly be wrong is defective windshield defogger or associated wiring. Now I am trying to find a way to isolate this circuit.
1) Has anyone else had experience whereby the windshield defogger was defective?
2) Where is connector X162? The electrical troubleshooting manual merely states located at the base of the windshield. Can this be accessed from the engine compartment area or from inside the car? Degree of difficulty to get to the connector to disconnect it? Or should I try to isolate this at the Aux Water Pump Relay?
3) Lastly I would love to relocate the hot lead for my horns to another fuse location. I can live without an aux water pump, jet heaters or windshield defogger. I cannot live without my horn, especially on Chicago expressways!! Thoughts??
Thank You
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.