Z3 Power top Issues - Reprise

I have seen a few posts dated from years past about Z3 convertible top electrical issues, but never heard/saw any resolution. Since my 2000 Z3 2.3 is still plagued by such gremlims, I shall pose the question
again to the now more experienced collective. Unlike some previous posters, my electric top did not nor permanently just stop working, but rather acts rather intermittently. Sometimes it will activate perfectly, sometimes it will work only if I hold down the raise/lower button for several seconds until it "wakes up" and jumps to life, sometimes it just will not activate no matter how long I punch and stab at it, requiring me to release the little valve on hydraulic unit in the trunk to allow manual operation. Yes, I always have my foot on the brake, and yes I always push the front of top up to enagage the small limit switch located up in the first articulated joint. And no, when I push the switch and nothing happens, there is no evidence or sound indicating the hydraulic motor is running, nor is there any evidence of binding in any mechanism.
There, that's the issue. I still love the darned thing dearly and it's only traveled 30k miles so far. I suspect either a short in the switch or in a relay somewhere, but am hoping somebody has encountered a similar problem and found the resolution which may lead me in an informed direction.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.