1992 cadillac eldorado wont start and stalls

i have a 92 el dorado 4.9L V8. and basicly it turns over and starts only if it is not touched for like 6 hours. and when i do get it started i put it in gear and it dies. the one time i did get it to
drive it stalled in the middle of the street. also when i attempted to start it there was no spark on my distriburator cap. and if i keep attempting to start it it floods. and when it did start (about a week ago) if i let it warm up and rev the engine while i was in park i could usually get it to drive a little. but once i slowed down below 10 mph or came to a stop the engine stall again. it has about 115,000 mile on it. and i didnt try to start the car for like 3 or 4 days as soon as i start it it stalls almost immediately or when it goes in gear it stalls. can some one help me please?? maybe the fuel filter? hopefully! $$
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Could be the ignition module. Before you go any further pull the codes from the computer. Turn the key to ON then simultaneously hold down OFF and WARMER on the climate control. Any stored codes, both history and current will come up on the dash display. When PCM? comes up, you're done. Post the codes here and we'll try to figure something out. FWIW YMMV
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
so the following codes say history after them: E026 E030 E052 E053 E061 E070 E091 E098 R033
i also get E012 current No IPC codes No ACP codes. thank you for the help. hope to hear from you soon
"nick" wrote
> i have a 92 el dorado 4.9L V8. and basicly it turns over and > starts only if it is not touched for like 6 hours. and when i > do get it started i put it in gear and it dies. the one time i > did get it to drive it stalled in the middle of the street. > also when i attempted to start it there was no spark on my > distriburator cap. and if i keep attempting to start it it > floods. and when it did start (about a week ago) if i let it > warm up and rev the engine while i was in park i could usually > get it to drive a little. but once i slowed down below 10 mph > or came to a stop the engine stall again. it has about 115,000 > mile on it. and i didnt try to start the car for like 3 or 4 > days as soon as i start it it stalls almost immediately or > when it goes in gear it stalls. can some one help me please?? > maybe the fuel filter? hopefully! $$
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Let's forget the history codes for now and work with current. E012 refers to a lack of a reference signal from the ignition control module. I'd remove it and have it tested. Many parts stores can do this. It is that crescent shaped flat part about 1/4" thick and 3" long that you will see after removing the distributor cap. Be careful removing the connectors. They will be very brittle after 14 years. Also inspect the wires going to it for fraying that could cause a short.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.