Battery light on

Have a 97 sts and the battery light came on. Had a squeal in the area of the alternator so i figured the alternator went bad. Replaced with another but
light came back on about 10 seconds after going out when starting. Turn car off and start again lite goes out and then back on after 10 secs and stays on also dash says battery not charging. Any body have same problem or ideas. Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

I'd check that replacement alternator. It wouldn't be the first time that a replacement, especially a rebuilt, was DOA right out of the box. Put a voltmeter across the battery terminals with the engine running. It should read about 13.6 volts or so, more immediately after startup.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Battery reads 13.6 with car running but battery lite still goes on after 10 secs of intially going off. also battery no charge comes on in dash.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
clean those battery cables caddy usses two layers of wires at the battery on the positive side. make sure its not all corroded and gross in their if you have a delco battrey make sure the positive terminal isnot leaking. i worked at a caddy dealer for several years and those doulble terminals are always a problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.