1995 camero stalling

I have a 1995 camaro that keeps stalling, it will run for weeks and then one day it will just start sputtering and the lights will kick on and off, like if the battery termals werent connected, then it will
die, I can restart it and drive down the road, but as soon as I hit a light it will die again, then I will restart it and no more problems for a week or two, I have changed the spark plugs and the spark plug wires and checked the battery cables, I am stumped. Please help Bridgette
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If you've already checked the cables where they mount to the body (ie: ground cable) and they both look fine, the only other thing that springs to mind for me would be the alternator. Sometimes they get sporadic when they're on their way out, but most of the time, they die slowly, and the symptom is more like "It's OK during the day, or when I'm not using any electrical stuff (radio, etc)...but with the lights on at night, it just can't seem to keep a charge in the battery..."
Wish ya luck finding the short...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.