88 camaro still won't crank

I got two problems only need one answer
Problem one:
88 iroc z 305 tpi automatic engine. I will be as detailed as possible, Car was wrecked front end
Bought the car for parts. car cranked drove car on to hauler myself. drove car off of hauler myself dissasmbled damaged parts on front end. ac compressor air pump water pump all were off of engine when i bought it , engine cranked and ran put these parts back on engine before rebuilding front end, car would not crank took every thing back off I put on the engine would not crank discovered distrubutor went bad replace with a distrubutor from 89 350 camaro, still would not crank have triple check to see that i was not off 180 degrees with help from guys who know chevy engines timing is correct had both ignition modules checked replaced electronic spark control with known good one ecm appears to be operational and properly working injectors are firing. check with a test light put ecm in limp home mode still no go it is trying to start but it's not hitting. fuel pressure is steady at 40 psi. compression check out at apx 90 per cyclinder , all info I have says that's good compression.I have good spark new plugs wires, new spark plugs properly gapped, Rotor button, distributor cap, fuel pump, filter, new fuel pressure regulator. all vacume lines are connected. Battery is fully charged and I have a 200 amp charger booster.
All logic says it should be running but it ain't
Problem two:
I am currently searching for two sticks of dynamite and a blasting cap :)
Thanx if I solve one of these two problems then the other problem will dissapear
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did you try cranking over the engine with the distributor cap off to make sure it is turning. Possibly a timing chain???

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes i did and i can see the timing chain as i have no cover on it right now

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
did that year come with a TPS (throttle positioning sensor) on/behind the Harmonic balancer? I ran into the same problem with my 1991 Mustang and that was the problem. When I took the balancer off to change the timing chain I broke it and did not know it.
--
"No one supported me, but all deserted me...but the Lord stood
with me and strengthened me" (2 Timothy 4:16-17).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
it has a throttle postion sensor but not behind the harmonic balancer it's up on the intake between the maf sensor and the plenium(sp) I've checked that but igh enuff it's currently 40 psi but several books said 42 to 45 psi i am not sure which book to believe right now
gonna recheck this week plus now I found out that maybe feul pressure isn't h

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hey retard, You are correct. You need to smoke a stick of dy-no-mite. Better yet, just get an early '70's Nova, like me, drive it from Detroit to L.A., and bug the shit out of the local cops. Watch out for the banana-in-the-tailpipe trick. ---Eddie
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Axel Foley spilled my beer when they jumped on the table and proclaimed in

If you are going to spoof a movie, at least get it right.
It was Beverly Hills, not LA.
NOI
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.