92 Camaro with major electrical problems

My 92 Camaro is a sweet old thing less than 100,000 miles and has been great. I have spent some money on starting to get it up to scratch. New alternator, starter motor, fuel pump, struts and shocks, was happy and
didnt mind as I did most of the work myself. Mechanics are far more important to me than looks.
Now she's letting me down big time. After finding a wet spot on the carpet I didnt know where it came from. The electrics seem to be failing progressively. In 24 hours it has gone from fine to the following not functioning. 1/. the knock sensor, 2/. the starter motor 3/. the fuel pump, et al. Now I realise there may have been some way for fluid to get in the back of the dashboard even though I have driven this car in driving rain with no leaks and the coolant isn't down. Are these systems on the same part of the wiring? I found a dead short in the wire to the starter I dont know where it was shorted as nothing showed but butchering a patch means it will turn over at least.
MAYDAY!!!!!
Monty
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
See if the fluid you mention feels "oily" If it is, you have a bad heater core. What is even worse is that radiator fluid conducts which will make a mess of your electrical system. One more thing, you have 2 computers in the dash on the passenger side. If those got it, you'll need to completely clean the wiring and computers with a mild detergent.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for replying! The fluid doesn't feel oily and there doesn't seem to have been a drop in the coolant levels. There does however seem to be no A/C any more which makes me think it is what blew out somehow.
I was a little suspect of it when the weather warmed up and the Air didn't get real cold. I know the evaporator is in a sorry state but found one for $90 delivered brand new. Guess I am gonna have to dissassemble the dash maybe.
I was trying to avoid it if possible! Further work with a multimeter and some side cutters has revealed the problem is between the bear stick and the firewall I think. the interlock switch thing doesnt seem to work at all and it was working perfectly the day befoe everything went to hell on a hand cart. Further suggestions welcome!!!!!!!!
Monty
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
it is your wire harness at the fire wall that is shorting out the ground. Fix it now or it will keep getting worse.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.