94 Camaro LT1/Engine Stumble or Hesitation at 1/2 Throttle

What could be causing an engine stumble/hesitation at half throttle when accelerating or under load, this only happens after the car is fully warmed up?
Also, any clue on how to increase heater output, once the mercury drops below 35, the heater is practically useless?
Any help would be appreciated!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

warmed
I can't help you on that one, I've never experienced that type of problem on my '93, but.........

.........I would suggest you back-flush your heater core. What I mean by this is have your heater core flushed from the opposite directon that the coolant usually flows. This will usually clean it out more completely allowing it to "heat" better once most of the deposites have been flushed out of it, that were insulating it internally.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When you mention, "after warmed up" you throw up the red flag for 02 sensors.
--



"Bralgar" < snipped-for-privacy@PRIcomVATEcast.net> wrote in message
news: snipped-for-privacy@comcast.com...
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.