Blinker/Electrical problems

I'm having a few problems with my 87 Camaro I just bought. If anyone has any tips for tracing down these problems, let me know.
1. The left blinker comes on and stays on when you turn it on; it does not
blink, solid light; and then it goes off when you turn it off. The right blinker is a little slow, but it works.
2. The bright lights do not work. I checked, and it is not a problem with the lamps. The bright indicator comes on inside the car, but the dims stay on and nothing happens with the brights.
3. The third/top brake light does not work. I replaced bulbs, and that still did not correct the problem.
If anyone has any ideas, please share. Thanks, Kirk
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
for the head lights check the wiring to the lamps themselves they tend to get loose and need to be squeezed, blinker- check the relay boxes they are seperate on the 85 not sure on 87. If u manage to find a wiring diagram let me knwo where u find it trying to find it for 85 camaro. hope i helped
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
for the head lights check the wiring to the lamps themselves they tend to get loose and need to be squeezed, blinker- check the relay boxes they are seperate on the 85 not sure on 87. If u manage to find a wiring diagram let me knwo where u find it trying to find it for 85 camaro. hope i helped
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.