no fuel 92 camaro

92 camaro 305 ,no fuel getting to throttle body,i have fuel coming out of both sides of filter,and pump is working just not pushing it up to t/b,i pinched off the return line at the tank and got fuel up to the t/b but
still would not run . it will run a long as i am pouring fuel in t/b . can the punp just not have enough pressure to make the injectors open ,the only way i got pressure up to the t/b was to pinch off return line. thanks for any help
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you can get pressure by pinching off the return line, it sounds as though your regulator may be bad. The regulator is located at the fuel inlet on the throttle body. I believe it takes about 15psi for a tbi system to work.
Gary

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks ,but the tbi unit has the regulator built into the throttle body, i have it fixed now anyway ,i pulled the pump and the hose that connect the pump to the supply line was in ruins. so i replaced it ,now everything fine . i want to thank everyone for there help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
90 mercury cougar 3.8 eng auto,when you go to start it the lights on the dash come on but it won`t start .then after you try it a few times it will finally start.,then this morning on the way to work the head lights wint out for a sec.i thinking it might be the ignition switch or a bad wire somewhere.appreaciate any help
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.