No reverse in 1995 Z28 w/ 5.7LT1

A day or so ago got into the car, shifted to reverse, it took a minute then it finally dropped into gear, it dropped very hard. Now the car wont shift into reverse at all. Rest of the gears are fine but no reverse. Does anyone have any ideas? I checked the fluid, the level was fine but it was real dark, almost black, and had a very slight burnt smell. So im kinda lost for ideas. All i can think is that is probably is gonna need a new trans. Any feedback appreciated in advance

~Nic
-- nick8519
-----------------------------------------------------------------------
View this thread: http://www.carstalk.net/viewtopic-426160.htm
Send from http://www.carstalk.ne
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Transmission needs a rebuild.....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
nick8519 wrote:

finally dropped into gear, it dropped very hard. Now the car wont shift into reverse at all. Rest of the gears are fine but no reverse. Does anyone have any ideas? I checked the fluid, the level was fine but it was real dark, almost black, and had a very slight burnt smell. So im kinda lost for ideas. All i can think is that is probably is gonna need a new trans. Any feedback appreciated in advance. Normally, at this point, the transmission needs a rebuild. While I don't know how often the fluid was changed, occasional changes (and filter change) could have extended the life some...
                    NOI
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.