Possible Transmission Problem - 2000 z28

I have a2000 z28 with auto trans. About six months ago I began to notice a slight out of evenness (vibration) during acceleration. I also began to notice the same feeling when I put the trans in low,
2nd, and regular drive, but only while accelerating. Then I began to notice the stange feeling when driving normally in either 2nd or regular drive. If I put it into overdrive the vibrations go away. Now it is really getting bad, especially when I try giving any gas while turning, it feels like the car is riding on the back wheels. I had the engine checked, everything was A OK. The car has 70,000 miles and is under an extended warranty. If I take it to a trans shop and they pull it apart and find nothing wrong then I have to pay the labor, about 300 to 500 dollars. So, does this sound familiar to anyone? Coould something other than the trans be at fault?
thanks g paglucio
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like a similar problem I have with my 94 Z28 with the 4L60e auto trans. I noted last year every once in a while while turning it would feel like the ass end of the car was going to slip out. (seemed loose), I thought there was a problem with the rearend. Also under acceleration appeared to be a problem with the rearend of the car. After a while I noted the car would "miss-shift". Then this year it got worse. 1'st to second seemed to miss-shift more. Then one day on the highway when I put it down to pass the car reved to the redline without it going into gear. Then over the next few days I noted the car making really strange noises and vibrations when turning under acceleration. Almost like a rear end or disk brake problem. Then suddenly there was a loud crunch from the rear while accelerating straighline. Now first gear is kinda there. Second gear is gone almost completely. Takes about a block to get it up to 25mph. then going into third is ok. as well as overdrive. Took it to a couple transmission places and they both said the same thing. Forward clutches in the auto trans are slipping/gone. Cost....... 1000$-2000$ to repair. Atleast get a full trans flush as part of the regular maint as it can actually prevent premature failure of the clutches if there is lots of crap in the fluid.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.