Question About A 91 RS

ok, just figured i would ask to see what you all would think the problem would be before i go do anything else....it's a 91 RS 3.1 V6 replaced the spark plugs, wires, distributer cap and button, now the problem i am having
was going on before i replaced all of that when the car is first started up after setting a while it runs fine but after it has warmed up and u come to a stoplight or any stop for that matter if runs like crap almost to the point of dying out and when u pull out it's like something is cutting back on the power and almost have to floor it to get it going it's runs better to drive it in drive instead of OD the harder the moter runs this less problem it has and when in OD is had trouble going because the engine itsn't running as hard anyone have a suggestion or thought as to what might be the problem before i go any farther with it...and one more thing seems like when it starts acting up you can smell a gas oder
--
The Anonymous Alcoholic! Drink 24:7
Copyright 2004
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I just went thourgh this with my truck.Any ways try cleaning your throttle body out real good and replace your egr valve. hope this helps
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.