Berlingo Limp Home Mode

Belingo van starts and runs fine up to about 2500 rpm then feels choked after that and goes into limp home mode - any ideas what to look out for?
TIA
HOG88 ~oOo~ ( )
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
you need to find a garage with a scanner, this can read the ecu and come up with a trouble code.
Could be just a glitch, but this will put the engine into limp mode untill the code is cleared.
They can erase the code to make it work again!! But it may not be just a glitch, if the same code comes back you will have to spend.
Regards Slim
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
HOG88 ( snipped-for-privacy@blueyonder.co.uk) gurgled happily, sounding much like they were saying :

Give us a clue...
Petrol? Diesel? XUD/DW8/HDi?
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just a guess, but HDI
Xsara Picasso's are allways going to limp mode, but I cant remember what the fault code reading was.
I think it may have allways been fuel pressure sensor, but not 100% sure.
Regards Slim
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Because it may be relevant to the original poster's problem, I'll repost a message I sent in Feb 2006 ########################################################### C3 SX diesel, bought December 2002.
About the middle of 2005, the engine warning light came on during a journey; I stopped and phoned the garage whence I bought the car.
I was told to wait a couple of minutes with the engine off; the system was being over-cautious. Good advice; that fixed it (and always has.)
However, it keeps happening, four times in one very unusual day during a journey of a little over 200 miles. Since mid December 2005, it's happened a total of nine times.
The garage seem puzzled; I was told to beware of driving too slow for the gear- go to gear n only at n*10 mph. They took details, saying that there had been other reports of this sort of problem. The exhaust recycling valve -have I got that right? -was mentioned after they connected it to their diagnostic kit..
Anybody else have a similar problem? The probability of my next car being a C3 was 90% a year ago; it's rather lower now. ######################################################### -- Per ardua ad nauseam
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi
Thanks for input, its a friends van and he says its a 2.0L HDI
Cheers
HOG88 ~oOo~ ( )

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.