C5 gone flat.

No not the tyres or the battery, but the engine. It wont accellerate until the revs are above the 2500- 3000 rpm mark, then it kicks in & flies as
normal. I have just tonight had the'service' light & the engine symbol come on. Yes i know i have to take it to the Citroen hospital, but its Sunday tomorrow. Any ideas guys ? Cheers. Ray
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
olddog wrote:

Petrol diesel lpg hpi hdi pi ????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oh sorry, 2L hdi diesel. I am a silly old Hector.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Blast from the Past!
Zaza and Kiki must have done something to the engine.
<http://www.thechestnut.com/hector.htm
--
-- ^^^^^^^^^^
-- Whiskers
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

MAP/T (manifold air temp and pressure) sensor wire come adrift (small), or variable geometry turbo not varying it's geometry (large) ....
your friends at citroen with the computer will tell you all I'm sure ...
bonne chance
S
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mmmm, cheers, it's gonna be the expensive one, knowing my luck. Cheers, we'll see on Tuesday.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Any news on this at all??
If it is the turbo if its in warranty then no problems. if its out of warranty get one from a written off C5 and just get it fitted by a local garage that you trust to do work and it should be fine :o)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well, it turned out that the 'air volume sensor', was faulty. So that was changed at a cost of 99. Very nice, BUT, now the turbo is screaming it's head off. I mean, it sounds like an American police siren. I have been quoted 650 to change it, by a Citroen specialist. I cant sell it with this noise so the guy told me to pull the plug out of the sensor & try it. I did, but the whistle is still there with no power. So i replaced the plug & now the service light has come back on with the engine symbol. The screen is showing "Anti pollution fault". Come on Adrian mate, whats the problem & what can i do ? Cheers. Ray

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did it make this noise before?
For them to have changed the sensor I imagine they would have disturbed the intake system considerably - make sure they've done every thing back up!
If it wasn't whistling before, and now it's whistling with AND without sensor connected it must be something they've done ...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes thats what i tought. No it was not whistling before, the guy said that with the air volume thingy working now, it has made the turbo work where it was not working before. I think its BS myself, yes it points to something he has done. Ray

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.