Citroen Xantia 2.1 td Exclusive

I have a Xantia 2.1 T D Exclusive. That has a problem with the windscreen wipers . The wipers will only work on slow speed and don't self park.( the car is fitted with a sensor on the screen) can any one
tell me where the timer / relay is fitted , or what the problem might be
Thanks Minty.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
( snipped-for-privacy@tiscali.co.uk) gurgled happily, sounding much like they were saying :

Almost certainly a problem with the motor itself.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Adrian wrote:

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@tiscali.co.uk wrote:

It is not the wiper motor as I have fitted it to my other xantia a 1.9 td lx and it works just fine ( still have not herd where the timer relay is fitted ) ?.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
( snipped-for-privacy@tiscali.co.uk) gurgled happily, sounding much like they were saying :

OK, if it's not the motor, and it's not a poor connection to the motor, it's almost certainly the ignition-switched "permanent" 12v feed to it.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Adrian wrote:

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@tiscali.co.uk wrote:

In pre-98 Xantiae, the wiper relay was under the habitacle fuse box/diagnose plug compartment (I'm not really sure where the hell is into an UK car: at your right, right?) I understand that post-98 cars should have the relays in the same place, but there are at least three relays involved: two for the rain sensor and one for the "regular" intermitent wiper.
http://img217.imageshack.us/img217/3324/relaybz4.jpg 12 and 13 are the rain sensor relays, 18 is the other one.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.