New C5 1.6HDi 16V LX Estate Burning smell

Ive recently purchased a Citroen C5 Diesel Estate, (heavily discounted managers special !!!!!) it now has 250 mile on the clock ive driven only short distances over
the last week.
On a couple of occasions when leaving the car after driving ive noticed a light burning smell. ive assumed as all is new there must be some oil or grease say on the exhaust being burnt off.
Today (Tuesday 27th Dec 05) something strange happend. ## a cold day 2 degrees centigrade indicated on the dash## I drove 5 mile and parked up to shop, and noticed a roaring sound as i opened the car door, the main radiator fan was going full belt and there was a VERY VERY strong electrical burning smell. I lifted the bonnet but could see nothing. Got back in the car started it, checked the engine temperature the needle pointing to straight down "6 oclock position" Normal, but still a strong burning smell. I turned the engine off but the fan was still going full belt, the burning smell now seems to have gone, I decided to drive along to the citroen garage 3 mile away, all the time the fan still running fast, when i got there the garage was closed so returned back to the car park where i had started, the fan still going. I got out of the car locked it but the fan was still going strong (bear in mind it is 2 Deg C outside and i have not been stuck in traffic and the engine temperature needle indicates the engine is normal, SO WHY IS THE FAN RUNNING). Worried that with the engine off and the fan running the battery would flatten i started the car and sat in it, I ran through the Diagnostic check accessable from the control panel, it showed no faults and passed whatever checks it does. After say 3 minutes then the fan stopped.
I have driven the car for short journeys since without problem.
It is possible the smell was brought to my attention because the fan was running and therefore directing the smell towards me i would have otherwise not noticed the smell assuming the smell is nothing to worry about. But why was the fan running on a very cold day when the car has just driven continuosly a couple of mile at 30 mph barring one stop a traffic lights. And continue to run for nearly 15 minutes.
Im looking for advice of similar experiences please
Thank you
micgent
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

New car, get it back to the dealer as soon as you can. It's their problem. This cannot be considered normal.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Took it back to the dealer, the fan problem they are aware of, there is a software update which prevents the fan from running on when engine stopped. This update was carried out a couple of days ago now and yes it has cured the fan problem. The same time they inspected the underside for anything that may be burning but nothing found. since the fan upgrade ive not noticed the smell.
Apart from that the car is superb, having said that i am comparing it with my old Seat Vario 1.9tdi X reg.
THANKS
micgent
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.