Wipers failed

During recent cold spell the wipers on my C3 failed. I have checked the fuse and that has not blown. I cannot here the wiper motor running. Can anyone please help

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

when you switc the wipers on have you tried helping them out a little
if something is frozen around the wipers... a device may stop teh motor to save it brning out.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My wife's C3 had wiper linkage break. Dealer told her at the time it was never heard of happening before. Today it was back at dealers again because fuel injector faulty. Same dealer but different person said the C3 had design problem with wiper linkage which is common problem in breaking.
Her wipers failed during cold spell too but they were 100% not frozen to windscreen when she turned them on.

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Andy wrote:

I had a C3 courtesy car - terrible car, outrageous amount of road noise cheap plastic everywhere, I've also had, in the past three weeks, a Xsara picasso (rubbish) cheap plastic everywhere, abysmal build quality, a vauxhall corsa (surprisingly good) and a vauxhall meriva which was also surprisingly good. heresy in this group, I know, but true.
I almost got my hands on a C5 VTR which looked fab inside and out.
RT
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.