Xantia HDi won't start

My Xantia HDi broke down last week on the motorway. The car just came to a stop. After I has tha AA tow it back home, I have charged the battery, tried ti start it. It turns over but won't fire up.
I have spoken to a bloke who said it may be the immobiliser that has kicked in. Any ideas how to reset/disable it. Oh, by the way, it is a 2001 HDi without the keypad immobiliser.
Thanks in advance
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Look for a mushroom shaped rubber button near one of the strut towers. Press down and hear it click.
You can also remove the connector and jump the cables directly to test it. Its a known problem.
--
Eduardo K. | Darwin pone las reglas.
http://www.carfun.cl | Murphy, la oportunidad.
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Cannot help with immobiliser problems but can you hear the fuel pump start (under the rear seat) when you switch on ? If nothing heard you might like to check the fuel relay (orange encapsulated unit near the engine management unit <£5 new) or the pump itself.
All the best
Gerald
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Gerald Gardner wrote:

Thanks, I will try again tomorrow. Just out of interest, how can I find out what all the relays are for and how to test them. Including the ones in the engine bay
Thanks xf8u
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have tested the fuel cut-off switch and it's fine. The fuel pump starts up when the ignition is swiched on. Any ideas what it could be?
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The solution for that was to disconnect the battery for 10 minutes, reconnect and try again. Something to do with the ECU getting its knickers in a twist.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.