Xantia Locking Problem

Hi guys, hope you can help
Got a 1994 M plate Xantia and have a problem with the central locking...
When using the key in the drivers door lock the central locking is not
activated at all, i.e. just the drivers door locks and unlocks. This also doesn't appear to activate the immobiliser keypad as I dont need to re-enter my code to start the car (?).
If I use the key in the passenger door then all the doors lock, then immediately unlock (including the drivers door). The immobliser keypad is activated.
For some reason the remote 'blip' doesn't work at all (although the little red led on the key lights up).
Could the problem with the locking be to do with the drivers door lock or the lock servo?
Do you think replacing the drivers door lock would remedy this?
Thanks in advance for any suggestions
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
bericht

The drivers door lock/servo might be the problem, if the passengers side is no problem. The drivers door lock is always used to open en close the door, so that one will malfunction first, due to wear.
Did you try the remote blip with a new battery? Sometimes the led lights up, but the battery is just to weak to send out the radio signal to the car.
Good luck
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sorted, took off the door panel and wriggled the wires around a bit and it worked! :)
Even the remote key works as well - bonus!
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Good Job!
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.