1982 Ford F100 Firing Order and help...help...help

*sigh* All right, it always seems it's my lot in life to do things the, well, not-so-easy-way.
I have a 1982 Ford F100. It has a 3.8L V6 with a 2 barrel carb an
and automatic transmission. No, no, no that's not a mistype, I realize it's rare, but that's what I have.
For some time now I've been plagued with an intermittant problem. I could be driving down the road, stopped or stopping at a stop light, making a turn and the truck would die on me. No symptom ahead of time except occasionally you might feel a brief moment of hesitation. I've also found no real way to duplicate the problem and the problem seems to be worse in colder weather (not THAT big of an issue here in Houston, Texas).
For the most part what I do when the vehicle dies is put it in nuetral and restart it then carry about my business. Last time the vehicle did this, a couple of the guys at work suggested it might be some type of problem in the fuel tank, that some net was collapsed. So I took the fuel line off and blew back into the gas tank with an air compressor and that seemed to work for about a year or so.
Then the other night during a cold-snap (please don't laugh you have yours we have ours) the vehicle died and would not restart. I even tried jumping it, all to no avail and I ended up having the vehicle towed to my brother's house.
Now I'm a computer-geek by trade, but luckily I have a brother who is a little more mechanically minded. He did some tinkering and got it working. So thinking it was crud in the tank again we blew out the fuel lines. Still no joy, the vehicle wouldn't start.
My brother did a little more tinkering and sprayed down the carb with some WD-40 and that seemed to fix the problem. He said that there was some carbon build-up on the carb and it was sticking.
Well it worked for about a week. Then on the way to work one morning it died again. The vehicle would not immediately start back up so I pulled over to the side of the road to let it sit a few minutes and try it again. After letting it sit about 10-15 minutes it started back up again.
When it started up it sounded a little funny, there seemed to be a whirring sound to the engine, I also heard a 'pop.' However, the truck was running, for a moment.
I managed to drive about 200 yards before the vehicle died again and no amount of pleading or cursing would get it to start up again. I thought with all the recent start-up attempts perhaps the battery was dead. I had one of those jump-start-in-can devices (I don't know what they are really called) and tried to jump it, again NO JOY. Truthfully it didn't even sound like the jump-start-in-a-can was making any type of difference whatsoever.
A couple of good samartians stoped to help me out and one of them had a larger jump unit that I did and we tried that. While it seemed to help the vehicle still would not start. We did a little more investigation and determined that the vehicle wasn't getting any spark to the distributor.
So second tow in about a weeks time. This time to my house. I called my brother and asked him what the problem might be (like I said he does cars, I do computers). He suggested the Coil. Since it wasn't that expensive and not that difficult to replace, I went ahead and got the part and did it myself.
That didn't work, so remembering what one of the samartians who stopped to help me said about a nut on the solenoid being lose and the connection sparking, I examined it.
Sure enough there seemed to be a little electrical scarring on the post nearest the battery. So I decided to replace the solenoid and the positive battery cable (I was going to replace the negative as well but jiminy crickets I couldn't figure out how to get that one out of there).
Now when I replaced the solenoid the entire vehicle went deader than a doornail. So I tried and tried and swore I had everything hooked back up right but could not get any juice anywhere in the vehicle. I thought I might try to jump it again and the minute I tried hook the battery cable to some type of ground on the live vehicle it looked like I was trying to arc weld. So I thought 'Well, that ain't right.' and decided to give up for the night.
The next day we pushed the vehicle over to my brothers house (no, we didn't manually push it, he got behind me in his truck and pushed me to his house)
Now no one could figure out why I wasn't getting any juice to the truck. So we replaced a couple of other electrical components in the truck (I THINK they were the Voltage Regulator and Ignition Control, but I can't swear to that) as well as putting another new Solenoid in.
Turns out I had one of the wires crossed on the solenoid. Once we figured that out we were able to try and start the vehicle but still no joy, but hey at least we were getting spark now.
Now after doing a little more investigation and tinkering we (well really he because at this point I was inside working on his computer) discovered another suspect part just off the side of the carb. Now we have heard this part called several things. Idle Stop, Anti stall dashpot, anti stall solenoid. On my truck this part is BOTH vacuum and electrical and gasket helping to maintain the vacuum crumbled into nothingness when he touched it.
So began the search.... I have looked all over this country for that part and not been able to find it anywhere
The manager at my local O'Reilly was very helpful. He came outside and looked at the vehicle (since the Truck will not run with out it).
We eventually ended up getting the tag number of off the carb and he looked the part up. Now we still weren't able to find the part but at least I feel better now about the name, according to him it's the anti stall solenoid.
I've looked all over calling at least 20 car parts places in 7 states and still nothing. I've been to Pick A Part and we looked at every Ford vehicle that wasn't fuel injected and nothing. Most of what we've found is EITHER vacuum OR electrical but not both.
Now I've also done some research on the internet and some of the groups say you should be able to run the vehicle without that part. However if we take that part off it won't idle at all.
Do you guys have any suggestions? I mean are we on the right track? Considering the newsgroups say the vehicle should run without the part is there maybe another problem? Do you have any idea where I can find the part?
If you want to see a pic of the part I've got an eBay 'Want It Now' auction that has a crappy picture, but a picture on it -
Anti Stall Solenoid
Ford Part Number - D7T9D857A (if this is the right part name)
Carb - e2Te D A A f 2e 25
Some of the places I've looked -
Champion Ford (Parts) - 281-579-9100 (Katy, TX) * O'Reilly Auto Parts (Fry) - 281-578-7070 (Katy, TX) Autozone (Fry) - 281-646-9233 (Katy, TX) Advance Auto Part (Fry) - 281-646-8485 (Katy, TX) Jeff's Bronco Graveyard - 248-437-5060 (Brighton, MI) Dennis Carpenter Repro - (Skip) 704-706-8139 (Charlotte, NC) Green Sales - (Dave) 800-543-4959 (Cincinnati, OH) LMC Truck Parts - 1-800-562-8782 (Lenxa, KS) Dream Sales - 1-800-543-4959 (?) Parts Voice - 1-800-328-8766 (?) JC Whitney - (Steven) 1-800-529-5003 X 7077 Pick A Part
I realize this was rather long, but I feel it's better to give too much info than not enough. Any help you could give me would be greatly appreciated
Now tonight we've replaced the distributor cap and rotor. And I can't find my Chilton book so I found the firing order on Autozone but I don't think it's right because the vehicle is running like crap.
Here is the order I found on the web:
Firing order 1-4-2-5-3-6
Distributor rotates clockwise -------- front | 1 2 3 | of | | vehicle | 4 5 6 | --------
If anyone could help with any of this I'd appreciate it.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

That is the correct firing order

6 5 4 3 2 1
Cylinder #1 is drivers side, front of engine (where the fan is).

I think you should consider a new vehicle... They've come a long ways in the last 25 years!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.