'94 Corvette keeps killing its battery

Standard 'vette convertible. Only 40k miles and nothing too special in terms of options. But, I've just installed the fourth battery in four years. Each spring the battery is completely dead though I try to
start the car once or twice a month during the winter. It's garage kept, dry, and rarely does it get too cold in the garage. This last time I couldn't even "jump" it on the full 100 AMP charger setting.
AAA loves me. The repair shop that keeps putting in new batteries under warranty hates me.
Climate control is OFF. Key is OUT of the ignition.
What could possibly be the problem her?. All the shop tells me is "you have to drive it because we can't find anything wrong."
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Get a battery tender:
http://www.batterytender.com /
You can find them for around $30. There are lots of different brands, they all do about the same thing.
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

yep, worked for me...
--
"Key"
=====



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Worked for me too. My '87 lives on one. The last battery lasted at least 11 years.
Mine's a Schumacher brand. But don't get $10 trickle chager. They don't have a silicon brain like the $30 ones.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.