C4 -battery replacement (1996)

Okay, I've done this a few times, but not with a Dry. Figured it suck a pain, go with the higher end battery.
Problem 1 - Got a Optima battery with dual mounts. The positive mount
was hitting a metal suspension brace, so I needed to cut the post. The sales guy said you could cut it with a hacksaw. No problem, did this. snipped the pan, no issue. Batttery went in okay, little tough with the cables. Car starts, put it back together, I'm done.........wrong.... next morning, dead.
Problem 2 - I think that the side terminals aren't making good contact, postive mount bolt is slipping. Get replacements, everything seems to mount fine, seems that everything seats well, but still a problem with the contacts...........put the old battery in, not problem with the connects....... Any suggestions?????????? Is there a some kind of washer to extend out the contacts, I think it's the postive cable mount since it seems a bit large.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dave wrote:

says the same as yours. I junked the Optima, and put in a new Delco. It has been great ever since. I had sent emails to Optima, but they took days and days before responding. I wouldn't do business with them again.
Regards, Jim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.