C4 GAS MILEAGE DISPLAY WRONG

I have a 1991 C4 which displays the average mileage per gallon wrong. It is always inflated. i.e. it will show 26 average when the true average is only
21. This is the fiorst time I have ever seen a car's computer average being wrong. Is ther a sensro that needs replaced or???
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

and to be truthful I never even used the gas milage function...
Bob Griffiths.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have you changed wheel/tire sizes along the way? I think doing so could throw off the sensor.
Ed B.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
But the odometer comparably incorrect also, so the error would not show up. I'm guessing the injectors were replaced with a larger size injector.
Ed Berns wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
As far as I know the injectors have not been changed. Would be very surprised if they had. Tires are original size and the speedometer seems to be correct.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Then it may be one or more is leaking, so more fuel is being used than the ECM is "injecting" thereby throwing it's calculation off.
jimbo wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
another thought here is that the avg mpg is calculated from the very first time it is activated. so it may be telling you that the avg mpg over the past 14 yrs is 26 but not recently because your motor is not as fresh as it used to be. i believe you can reset the display also by holding down the button of so... look in the manual on how to reset the display then see if the avg mpg is consistant with what you calculate by hand after the sensor was reset. let me know what happens.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.