C5 / Z06 Question

I recently purchased a white 99 C5 hardtop. The previous owner had applied Z06 logos on the front fenders just behind the front wheels. The dealership I bought the car from removed the logos and now I'm left
with residue in the shape of the logo that is impossible to remove - trust me...impossible. Heat, chemicals, etc...nothing works. It's not too noticeable, but I sure notice it. I could 'fix' this by putting the Z06 logos back onto the fenders. Should I? Thanks for your opinions...
FYI - the car has lots of after market Z06 accessories - vent screens, an intake behind the door, etc, so essentially this is a Z06 body (5.7L engine)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

if its NOT a zo-6 ? then the logos should NoT be there. quiet a difference in a xo-6 and a 99. see a paint shop...
my2
--
'Key
=====



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You could get these.....
http://www.mamotorworks.com/corvette-1-41-3010.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's the same shape - I'm a newbie to Corvettes - what is an LS1? I'm Googling it, but I thought I'd ask. Thanks for the suggestion.
LotzaLoot wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The engine type id for the '99. For instance the ZR-1 of the 1990's has the LT5 while the other corvettes had LT1 or a LT4 in 96's with the 6 speed.
Roscoe wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Bob I & LotzaLoot! I'll use LS1 emblems and not feel like I'm putting bogus emblems on my car. The Wikipedia description of the C5 says:
'The transmission was moved to the rear of the car to form an integrated, rear-mounted transaxle assembly which was connected to the all-new LS1 engine.'
http://en.wikipedia.org/wiki/Chevrolet_Corvette_C5
Thanks again guys!! :)
Bob I wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

pattern you want to be careful, a little off and they will look like crap. Stretch strips of masking tape between two repeatable points so you can repeat location both sides, vertically and horizontally. Any marks required can be put on the tape with a small relief for the oval to clear. Tape location can be tweaked easily but the emblems won't move very easy once you stick them on.
--
Dad
05 C6 Silver/Red 6spd Z51
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
that's so tacky...buying a C5 Corvette, then applying the Z06's decals/accessories to make it look like it's something it's not.
not that i have anything against the C5, or C6...but just don't make something out that's not what it is.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I agree - that's why I solicited opinions here (and thank you for yours). The previous owner did it- not me. I'll use the LS1 emblem to cover the marks left as it does have an LS1 engine. This car is spotless inside & out except the fender marks where the old emblems were (white paint shows it even more). It was bugging the heck out of me... Thanks again
Lawrence Lugar wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.