Electrical whine -C5

I have a new whine in the car, sounds electrical. The alternator is still putting out ~13.5 to 14 volts under load at fast idle. I can't tell if it is coming through the speakers or not, doesn't seem to be
radio related. I run XM on a direct feed. Any thoughts on anything I should check before the investment in a new alternator? Thanks, FBNE.
'01 C5 red, no mods
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You need to check, clean your grounds on the frame rails, both sides, and add any capacitor/suppressors required to fix the addition of the XM feed. How is the XM not a mod on an '01, is it a stand alone system?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dad wrote:

Okay you got me there on the XM. I did manage to hide the antenna under the rear body panel and the control head under the ash tray cover. I will check the grounds. The XM has been in place for 4 years, the whine started about a month ago. I divorced the other bad whine coming from the left seat, so I know it isn't that. FBNE
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
FBNE wrote:

Genius.
Venger
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Snip- - Cut to the serious side.......

Well if she was in the left seat I would have to.
Good luck on the grounds if that will do it, may be covered with small stones. I vacuum them out when I clean the car to keep them from collecting dirt and moisture.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dad wrote:

She was. "I wanna drive, I wanna drive." Had to go.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That's the problem. The whine comes from the right seat.
-W
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dad wrote:

I checked all the grounds today.. No luck, is there a module in the alt that can be changed out? It is coming from the alt, as the pitch of the whine is related to rpm. I show good output voltage. FBNE
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.