no oil to motor

I've done everything and still to oil being pumped to the motor. HELP!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sean wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

1981 corvette. yes it starts. god thing i always use great oil.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

one day the car is running great. the next morning no oil is pumping?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sean wrote:

How did you decide there wasn't any oil pumping?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

noticed noise in the motor. took the valve covers off and cranked it up. no oil flowing to the top of the motor
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bad gage...????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sean wrote:

So did the drive tang shear off the end of the distributor?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Prior to the oil failure did the engine backfire...?? If so you could have stripped of the oil pump drive on the distributor..Did you pull the distributor and check it out...??? Did you prime the new oil pump...is the pickup clean..???
Complete failures like you had should be the easiest to fix its' the intermittent failures that are a bitch to correct.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.