Poor performance at 85 mph on my 88 C4

Does anyone know if the factory installed a speed control or RPM limiter on 88 C$'s. Mine runs very rough, and seems to be misfiring at 85+. Any suggestions for resolving?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
lifeskills wrote:

gas? Plugs & wires? HEI coil, distributor & module? The long shots: Knock sensor is signaling the Electronic Spark Control to retard the spark.
Does it feel like it's leaning out? Fuel pressure slump?
As these cars age, we hit 'strange' problems like primary ignition wiring faults and failure to pull enough ignition current. I'd not expect that to show up at 85 but it might be worth a look if everything else checks out.
--
PJ
'89 auto coupe, '02 6-spd coupe

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

maybe stopped up gas filter ?
--
"Key"
=====




Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No rpm or spped limiter was installed.....check the following...
Fuel filter fuel pump in tank filter fuel pump fuel injectors spark plugs spark plug wires dist module egr valve egr valve control module
One of those should be your problem..check in the order shown...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dad wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.