Service Engine Soon Code P1153 & Rough Idle

96 LT1, 101K miles, Auto
My car started overheating the other day in stop and go traffic, I pulled over into a car wash and sprayed water on the radiator and it started to
cool down. It got up about 234 degrees. The last two years it starts to overheat on real hot days and in stop and go traffic. I'm thinking I need my radiator swapped out.
But, my question is after it cooled down and I noticed that it was kind'a shaking at traffic lights. Then today on the way home my Service Engine Soon came on. AutoZone read the code and they said it P1153 and that it was a dealer code that they would have to check. Their equipment didn't go that high??? Wondering if anybody has any ideas on what might be my problem. I don't have any oil in the water and no water in my oil.
Any advice will be appreciated.
Thanks, RP
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually you probably need to clean the debris from between the A/C condenser and the radiator.
As for the code
P1153 = HO2S Insufficient Switching Sensor Bank #2, Sensor #1
from the autozone page on 96 corvettes http://www.autozone.com/az/cds/en_us/0900823d/80/21/f7/f6/0900823d8021f7f6/repairInfoPages.htm
RP wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.