Turn signal problem 98 GMC Sierra

I have a 98 GMC Sierra K-1500 with 289k miles on it and have the weirdest problem with the turn signals. Truck has been flawless (and trouble free) up to now. I had to replace the turn/wiper/cruise
stalk due to a non functioning washer switch. Everything else was working OK. Ordered a new stalk from the dealer, took the old one out and put the new one in. Now, everything works except the turn signals, which work, but not correctly. When you turn the left blinker on, the rear left lamp flashes, but the front RIGHT and right dash light flash with the left rear. Same thing happens for the right... right rear, left front and left dash. It took 2 hours to replace this one and I hate to have to do it again twice (put the old one back in, get a new stalk from the dealer and then do it again), but i will if I have to. i almost want it to be the stalk, but I don't think it is.
Anyone ever see this before or have any suggestions? The dealer said it might be trailer wiring, but we pulled the rear 7 way plug ff completely and that didn't change anything. I'm at a loss to explain it.
HELP
Chuck
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
---snip---
see another dealer that deals with a (98 GMC Sierra)
-- "Key"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.