'03 Neon AC problem

Just bought an '03 Neon.. 56000 miles.. nice little car- runs great, looks brand new :-) However, after 2 days of limited use, the A/C quit working.
A friend of mine who knows something about cars looked at it.. he added freon, then checked the relay..switching relays didn't cause it to kick on, but trying to bypass it by putting a paperclip (I think) into there caused it to kick on... so, WTF? Obviously the compressor's working..when it did kick on it was pumping nice cold air.. any thoughts? He told me to buy a new relay switch today which I will but neither of us sees how that'll help since switching out relay switches that are identical had no effect... Thanks for any insights.. John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check all the fuses first. The problem is in the control side, which could mean low freon to begin with. Did he use a gage to fill the system? Second thing to look at is the pressure switch and its connections. Sometimes they come loose, sometimes the switch itself fails. I'd try shorting that, too just to see if it is at fault. The control side is pretty simple. Either you have power to and from that pressure switch, or you don't. I don't visit here often, okay to email me with questions. George
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 10 Dec 2006 20:43:40 GMT, "George Jaynes"

Dollars to donuts the condenser is shot. The guy who sold it to you got it charged to make it work to sell. Illegal here in Canada to put freon (of any sort) into a leaky or unproven system.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.