1994 Dodge Caravan

My Daughter's 1994 Caravan will not shift into overdrive. The Tranny was rebuilt a couple of months before she bought it. The motor does reach normal
operating temp. What can be the cause?
Buster
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the electronic valve body is the problem real common problem the all do it and they are not cheap to replace
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Buster wrote:"My Daughter's 1994 Caravan will not shift into overdrive. The Tranny was rebuilt a couple of months before she bought it. The motor does reach normal operating temp. What can be the cause? Buster"
******************************************* How many miles are on the vehicle, which engine? Was it a reputable shop that rebuilt it? There are many upgrades required to be installed into these during a rebuild, including the controller. I had all kinds of problems with a 604 when they failed to replace the controller -- which had undergone at least two upgrades. In other words, when I finally took it to a reputable shop, they mentioned that this 'rebuilt transmission' was still using the first generation controller, where by that time it should be the third -- so naturally the unit was not compatible with the upgrades hardware included in the rebuild kit, and wouldn't control it properly. I'm not saying there's a high probability that's the problem with yours, just that there are a LOT of upgrades on those, both inside and out. Are you sure it's not shifting into overdrive, or if it's the torque converter lockup not working?
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On May 4, 8:08 am, snipped-for-privacy@webtv.net (James Goforth) wrote:

i replaced many of these transmission with factory rebuilt transmissions and they too had problems with the electronic valve bodys with the big computer plug the 604 were noted for the snap rings breaking and then you know what happens next they go to shit real fast but they also have problems with the valve body good luck with your problem .
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Buster52 wrote:

I have one with a similar problem. It seems to overrev in each gear, and doesn't shift into overdrive. If I drive a few miles, then shut it off and restart it a minute later, everything works great. One time on the freeway, it went into neutral - engine just reved up until I let off the gas. Coasted down to 40-45, then it started working again, but with the no-overdrive, overrevving problem until I turned it off/on again.
The previous owner had the overdrive solonoid replaced, with no improvement. A dirfferent shop removed the computer to try a substitute one, and claimed the problem went away, and stayed away after re-installing the origional one. I bought it, and the problem came back a few days later.
Could this be a speed sensor or temperature sensor problem? Any other ideas.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bob F wrote:

Oops. 3.3L 3spe w/overdrive.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

    Possible worn throttle position sensor, making intermittent contact.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.