1999 Caravan Climate Controls

I recently purchased a 99 Grand Caravan- and when I brought it home none of the cimate controls would work at all. Very quickly I realized that the battery in the van was so bad that when I got home it wouldn't
start and it refused to take a charge. After replacing the battery- the fan switch worked, but none of the lights for the a/c, defrost, and rear wipers would light up or respond. Now its a situation where occasionally when I first turn on the key- they light up and function, but after hearing a relay in the fuse box under the dash either click once, or start to click repeatedy- the lights go back off. I tried to get it to go into test mode- and it starts- but after a few seconds (and that relay clicking the whole time) - all the lights go off again. I tried swapping the relay with another identical one- with the same result. Does this sound like the climate controls need to be replaced, a relay issue, or something worse. Thanks SO much for any help you can give me- this is driving me nuts (and killing me without being able to turn on my A/C in this lovely 90 degree heat).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Without having a scan tool to read any and all faults in the body control module and climate codes, it would be hard to give any kind of advise.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.