2000 Caravan BCM update

Hi all, just an update on my Caravan 3.3 The oil pressure light and chime would come on intermittantly and sometimes for 30 sec or 20 minutes and so forth. Sometimes not for a day or two. The Dodge
dealer here has been great. They had it twice, checked the pressure and that ok while the light was on and also even removed my sender and installed a dodge sender with no luck and then put my sender back in. They did not charge for any of this. They talked with Dodge central and had it back again to check a couple of other thnigs with no luck. This all while it may or may not show symptoms. We then decided to order a new BCM and that went in. All ok for a few days, but then again a chime for a minute or two then ok. Yesterday they programmed it again and hope it stays this time? Oh, and they also did an open recall on my clockspring too. Leaving for Colorado tomorrow so will let you know if the problem is indeed fixed Thanks for the advice before, Jerry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Jerry if the BCM didn't fix it when they put it in, there is no programming that will fix it. If you have a contaminated oil sending unit wire connector it will cause this. If the lite comes on again, remove the connector and pull out the rubber seal, clean the connector good and leave the seal out.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 21 Sep 2007 16:39:15 -0400, "maxpower"

also apply if the sender is not connected at all?. Would the contaminated connector still cause a fault if not connected? I did disconnect the sender a while back and the light still came on. Thanks, Jerry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

NOPE. if the sensor is disconnected and the lite still comes on you probably have a problem with the instrument cluster circuit board
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.