2001 Durango SLT cruise control

My Durango 4.7L (65k miles) is having a problem with cruise control. The CC will not even turn on. The "Cruise" indicator on the dashboard won't turn
on no matter how firmly you press the button on the steering wheel to turn it on.
However, if I stop at a red light and cut the engine off, then crank it back up, there's a good chance that CC will work just fine.
If it will turn on initially, then I can turn it off and back on at will, and it will work perfectly for as long as the vehicle keeps running. The next time I start the engine, the CC may not work -- if so, it won't work at all unless I cut the engine off and back on again.
So it doesn't seem like the switch on the steering wheel -- maybe the BCM?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
--

"Marcus" < snipped-for-privacy@b.n> wrote in message
news:AaHhg.50308$ snipped-for-privacy@bignews6.bellsouth.net...
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, Glenn, I'll arrange to take it in to the dealer.
I appreciate the response. I know everyone here appreciates getting your expert responses here.
Regards, Marcus

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you Marcus
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hey Marcus, let me know what you find. I have a similar problem with my Durango 5.2, except I've found that it will come on if I keep pressing the "on" button. It always comes on, but only after a few tries. I was going to try contact cleaner.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well, actually, the problem only occurred on one day.
Which day? June 6. 06/06/06.
Since then, perfect behavior.
(looks at Glenn for an explanation of the evil subroutine in the PCM/BCM that only activates on 6/6/6)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.