2002 stratus transmission problems

Hello everyone, I have a 2002 Dodge Stratus with 80,XXX miles on it. 90% of the time when it is in park or neutral, all of the squares light up around P R N D 3 L (or what ever they are) as if I currently have
all of them selected. That may be important. The real problem I have is that every once in a while, when I put my car into reverse, they all stay selected for a few seconds, then it SLAMS into reverse and the check engine light comes on. This only happens about once every 2 months, but it fells like a neutral drop and I am sure my transmission doesn't like it. It is also shifting hard every once in a while. Does anyone have any ideas of what may be wrong?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hmmm, i haven't retrieved the error code yet, but in looking over the list of codes, I see a park/neutral switch failure code. Since my car has no idea what's selected when in park and neutral, this sounds to me like a possibility. What do you think
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well, I went and got the error codes retrieved. P0841 and P0700. P0841 is a transmission fluid pressure sensor, switch "A" circuit range/performance. P0700 is just a follow up code according to the advance auto guy. I have not found any resources on the net for troubleshooting this. Does anyone have any recommendations? I don't want to just replace the switch blindly
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.