2003 sx 2.0/neon problems

Not really problems, more annoyances. The fan's cut in pretty much all the time at idle, even now when it's pretty cold out. It cuts out for 15sec every now and then. Also, I have this big hole in the powerband
at 2600rpm. It's in every gear and as soon as it gets to 2900, the car surges forward again. Sucks on hills, as the revs are usually below 3000, so I'm down to 40-45mph sometimes. Finally, do these cars have grade logic transmissions? Mine seems to. I can kick the trans down to 3rd gear easily on a hill, but then nothing I can do will get it to go back to 4th. I can almost completely lift off the throttle and it will not upshift. But, as soon as the car becomes level again, it goes in perfectly. The car's an automatic btw. So basically, I come to a hill and decide to pass someone, so I run out of power when the engine dies out, then I kick it down to 3rd gear, and it won't go any more than 55 mph because I can't get it to upshift. So, in fact, I can't pass anyone. Anyone have any ideas/experience? Thanks! I relize I've been a bit short on details, lemme know if you need to know anything else.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 23 Sep 2005 01:30:30 +0000, Kylie & Kelly wrote:

Not much you can do about it. That's how tiny cars with lawnmower engines in them perform. Get a bigger car with an engine in it.
--
If you're not on the edge, you're taking up too much space.
Linux Registered User #327951
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Great answer, shitbag. I'm still watching you, hillbilly.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.