2004 Stratus Heat Problem

I have owned the car for two years now. Whenever the car idles I get no heat to come from the vents/defrost no matter what the water temp gauge says. As soon as the RPMs reach 1800 or so the heat will kick
on. I am guessing I need to replace a thermostat, am I on the right track here?
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

level in the radiator... You will probably find it to be low causing this problem. Then find out where the leak is.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Anyone?
"cls321" wrote: > I have owned the car for two years now. Whenever the car > idles I get no heat to come from the vents/defrost no matter > what the water temp gauge says. As soon as the RPM's reach > 1800 or so the heat will kick on. I am guessing I need to > replace a thermostat, am I on the right track here?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Any one what? did you not read my reply or did it not go thru?
2nd reply No you are not on the right track!! The right track is gonna be check the level in the radiator... You will probably find it to be low causing this problem. Then find out where the leak is.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.