2007 Dodge Nitro

Hello everyone, I am new to this group and have a question. First I want to say that I am a lover of any Dodge or Chrysler vehicle. I am having a
strange problem with my new Nitro when traveling at speeds of 35-40mph. It feels as though it shifts into a low gear and kind of lopes and runs rough. I have taken it to 2 dealers in the area and thay say that they cannot duplicate the problem. My wife was driving it the other day and felt as though the engine was going to quit when she was going 40mph through our neighborhood. The best way to explain it is putting a standard transmission in a higher gear at low speed. Is there anyone with the same problem? Thanks in advance.
J. Fields
2000 Durango SLT 2007 Nitro SLT
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I read about similar problems in other Dodge and chrysler vehicles. Sometimes they can try to reprogram the electronic setting. Not sure about this model. There is a web site called Alldata they have a lot of information to hunt down problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply. I ahve an appointment this week for a software update.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.