4spd trans help

Hoping some people can help with guesses as to what is causing a shift behaviour problem with my transmission. Vehicle is a 2000 Dodge GC with 3.8L
and 4spd auto. When the vehicle is cold, has to sit a few hours or overnight, the transmission will slip when shifting from 2nd to 3rd. Just a momentary slip with engine climbimg 300-500rpms before the gear catches. It will only do this approx. 3 times when going from a stop then I am on a 20km stretch of road and everything warms up fine. Once the engine is at operating temp, and presumably so is the transmission it will shift fine from 2nd to 3rd. No noticed slip from 1st to 2nd or 3rd to 4th at anytime. FLuid is ATF+4 and was changed 30,000km ago. Only other thing was the speedo once went from 0 to 200 when stopped at a red light then back to 0. Van goes into a Chrysler dealer on Sat. for a look. Anyone want to post ideas and thoughts, I will post what the dealer comes up with after they diagnose it. I know there is not alot of info here to diagnose, if someone wants more ask I will try and answer the question. Hoping it is not something major as these vans do have quite the reputation for trans problems. It is also my first Chrysler product.
TIA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.