94 Caravan 3.3 no water circulation

Hello, lately I havent been getting any warm heat from my van. I replaced the thermostat. The old thermostat was stuck open. OK, that worked I got
heat, but I noticed that there was no water circulation and when I revved the engine it would get warmer then when it was just idling. I turned the heat up to high and revved the van till the fan kicked in. I pinched the hose again and nothing no water circulating at all. Does anyone know of a way to check it the water pump is pumping or what would be my next step without spending too much to diagnos the problem ? Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

replaced
got
First of all where are you talking about water not circulating? in the radiator? heater core? To check to see if your water pump is circulating that would be easy to do. If you don't have an overheating problem now, then it is circulating!! If you are referring to not having enough heat the first thing to check is the temp of the coolant going into the firewall where the heater core is. If it is hot going in and cool going out the heater core is stopped up up. Assuming the system is filled up properly.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Then Glenn, when I mentioned it wasn't circulating, I meant the top hose of the rad going to the thermostat. I would squeeze that hose and it would be hot but it wasn't building up pressure. Thats why I thought it wasn't circulating. The van doesn't overheat. I hooked up the garden hose and did a backflush on the heater core. It seemed to flow thru no problem. I do have heat but I thought for some reason that the water pump was bad. The heat in the van never really seemed that good to me. Thanks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oops,,, thanks Glenn !!!! not then glenn.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had a 3 litre caravan which wouldn't build up pressure, although it didn't consume coolant and ran at normal temp and provided warm air from the heater. The radiator cap was the reason for no pressure and needed replaced.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.