95 Neon Only Firing Off #2 Injector

My 95 Neon is only firing off #2 injector. I tried changing injectors cam sensor and tried two different used ecms.The motor is only running off one cylinder it has new plugs and wires and a new coil with one of
the ecm it was running off #3 than I put the original back on it went back to running off #2 again. Any help would be greatly appreciated
--
Posted at author's request, using moderated http://www.AutoBoardz.com interface
Thread archive:
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 27 Apr 2008 22:22:13 +0000, rraamm2 wrote:

Take it to the nearest junkyard, and take the $100 they'll offer you for it.
--
"Ubuntu" -- an African word, meaning "Slackware is too hard for me".
The Usenet Improvement Project: http://improve-usenet.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

is this car auto or stick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

this is what you do the wire harnest runs next to the egr and hot water pipe look for wires that either got burned or rubbing on the pipe and if it is a stick see if the clutch cable rubbed through the wire harnest under the fuse box by the battery
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.